Charles Greathouse on Fri, 29 Jul 2011 06:44:19 +0200

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

gp2c trouble?

I just built and installed the latest versions of gp and gp2c

GP/PARI CALCULATOR Version 2.6.0 (development git-982909e)

(there's no version number on gp2c that I can find, but it's the git
version from an hour ago).  gp runs and passed the bench, and gp2c
similarly runs and seems to have access to the 2.6.0 functions:

$ gp2c -l | grep 'ellheegner'
ellheegner ellheegner G

But when I try to load my gp2c file in gp it fails:

  ***   Warning: is not a GP binary file.
  ***   error opening input file: `'.
  ***   Break loop: type 'break' to go back to GP

I get a similar error if I use gp2c-run:

$ gp2c-run

/ cannot open shared object file: No such file or directory

  ***   at top-level: install("rev","GD10,
  ***                 ^--------------------
  *** install: couldn't open dynamic library '/'.
  ***   Break loop: type 'break' to go back to GP exists and looks normal to me in a hex editor.  What could
be going wrong?

Charles Greathouse
Case Western Reserve University