Phil Carmody on Wed, 24 Jan 2007 17:38:16 +0100

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

GMP build on OSX

I've just tried to build 2.4.0-alpha with a GMP kernel on OSX, and Configure
has barfed at me:
Checking for optional libraries and headers...
...Found libgmp in /usr/local/lib
...Found gmp header in /usr/local/include
### Your version of GMP is too old for PARI. Please upgrade

My GMP is '4.1.4' I think but the libraries name themselves as follows:
geespaz:~/development/pari-2.4.0.alpha phil$ ls -al /usr/local/lib/
total 4432
drwxr-xr-x   7 root  wheel      238 Nov 19  2005 .
drwxr-xr-x   6 root  wheel      204 Nov 19  2005 ..
-rwxr-xr-x   1 root  wheel   982596 Nov 19  2005 libgmp.3.3.3.dylib
lrwxr-xr-x   1 root  wheel       18 Nov 19  2005 libgmp.3.dylib ->
-rw-r--r--   1 root  wheel  1270456 Nov 19  2005 libgmp.a
lrwxr-xr-x   1 root  wheel       18 Nov 19  2005 libgmp.dylib ->
-rwxr-xr-x   1 root  wheel      705 Nov 19  2005

I think I desperately need a GMP build, as I'm doing number-crunching on quite
large numbers where GMP's strengths come to the fore.

I don't believe there's a problem with my GMP version, I simply think
config/get_gmp is using an inappropriate test, and flagging a false negative.

Can someone please either give me hints how to fix the problem, or arrange to
ship me a prebuilt G5 binary. 


()  ASCII ribbon campaign      ()    Hopeless ribbon campaign
/\    against HTML mail        /\  against gratuitous bloodshed

[stolen with permission from Daniel B. Cristofani]

It's here! Your new message!  
Get new email alerts with the free Yahoo! Toolbar.