Alain SMEJKAL on Thu, 04 Jan 2007 00:15:56 +0100

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

Cygwin buid

Dear List,

1) A try to buid Pari using Gmp lib failed at link with many undefined
Does someone may help ?
Note : Gmp lib used is a fresh buid from version 4.2.1 and has been
successfully self-tested and linked with other computational tools.

Buid env :
Pari version : pari-2.4.0.alpha
Cygwin binaries version 1.5.17
gcc version 3.4.4 (cygming special) (gdc 0.12, using dmd 0.125)
additional gcc path setting for Gmp via LIBRARY_PATH=/usr/local/lib:

Sample of errors :
Creating library file: libpari.dll.a
mp.o:mp.c:(.text+0x3ad): undefined reference to
mp.o:mp.c:(.text+0x62d): undefined reference to `___gmpn_sub_n'
mp.o:mp.c:(.text+0xbaa): undefined reference to `___gmpn_lshift'
collect2: ld returned 1 exit status
make[1]: *** [libpari-gmp-2.4.dll] Error 1

2) Classical buid (without Gmp) reports many suspicious lines at doc
generation stage.
How do I have to handle that ?
A quick look, using Yap, of produced dvi files does not show evidence that
something went wrong or not.

Sample of reports :
tex libpari
This is TeXk, Version 3.141592 (Web2C 7.5.4)
 file:line:error style messages enabled.
 %&-line parsing enabled.
(./libpari.tex (./parimacro.tex (./paricfg.tex)
No aux file.) [1] [2] [3] (./usersch4.tex [4]
Reference `se:prog' on page 5 undefined on input line 29
[5] [6] [7]
Reference `se:impl' on page 8 undefined on input line 219
[8] [9] [10] [11] [12] [13] [14]