Bill Allombert on Fri, 03 May 2013 19:38:48 +0200

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

Re: Problems with elldivpol - will they be fixed in 2.6.0?

On Fri, May 03, 2013 at 05:57:58PM +0100, Richard in Reading wrote:
> I obtained pari-2.6.0.svn13433.tar,gz from the website and built it in an
> attempt to escape apparently incorrect elldivpol results which plagued
> previous pari versions for unix.

Hello Richard,

How did you find pari-2.6.0.svn13433.tar ? This is a very outdated snapshot
from 2011-09-04. I will remove it.

> By contrast I have a version [2.5.1] running on Windows which apparently
> doesn't suffer from the same problem in this instance.

Indeed, elldivpol was fixed in 2.5.1 but not in svn-13433 which is older.
It is fixed in git-87803f303 in 2.6:
Author: Bill Allombert <>
Date:   Sat Jan 14 21:30:02 2012 +0100

    DS 51- elldivpol returned wrong result for degree n >=8.

> Does anyone have a good idea of the state of bugs in elldivpol for 2.6.0 ? I seem to be completely unable to do the relevant work with elldivpol on a non-windows machine.
> I would be very grateful to receive instructions on how to build a version that gives the correct results! 

I suggest you simply install PARI 2.5.3 from