Ewan Delanoy on Sun, 16 Sep 2012 14:20:20 +0200

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

Re : Cannot install PARI-GP on Mac OS 10.8

> So maybe you have two different copy of readline.h

I do have ; I first tried installing GNU readline. The result was dubious, as the compiler finally said "Perhaps you should use ldconfig." A google search informed me that I was not the only one with that problem, but according to some  there was no need to worry, the system had indeed readline installed but wasnât aware of it. Dissatisfied with this, I also installed readline with MacPorts independently. This second installation went fine according to MacPorts, but I still get no answer when I type "readline -v" in the Terminal.

>When you run Configure it should say something like
>  ...Found libreadline in /usr/lib64
>  ...Found readline header in /usr/include/readline
>  Using GNU readline, version 6.1
> What does it say on your system ?

It says this :

...Found libreadline in /usr/lib/
...Found readline header in /usr/include//readline
...Found history header in /usr/include//readline
...Found libncurses in /usr/lib/
...Library ncurses needed by readline
...Library readline does not have rl_save_prompt
......but it has _rl_save_prompt
Using GNU readline, version 6.2
Installation prefix ? [/usr/local]
...for architecture-independent files (share-prefix) ? [/usr/local/share]
Installation directories for:
...executables (gp, gphelp) ? [/usr/local/bin]
...libraries (libpari) ? [/usr/local/lib]
...include files ? [/usr/local/include]
...manual pages ? [/usr/local/share/man/man1]
...other system-dependent data ? [/usr/local/lib/pari]
...other system-independent data ? [/usr/local/share/pari]
Default is dynamic executable and shared library