Bill Allombert on Thu, 17 May 2012 18:08:23 +0200

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

Re: cannot compile readline back in updated version of gp

On Thu, May 17, 2012 at 04:40:29PM +0200, Ewan Delanoy wrote:
> Hello all,
>  as I am currently updating to pari-2.5.1, I cannot enable readline back in even though I'm following the instructions step-by-step at the very end of the FAQ at
>  In particular, the "configure" step appareantly works without problems : the output in the terminal includes
>  ...Found libreadline in /usr/local/lib
>  ...Found readline header in /usr/local/include/readline
>  ...Found history header in /usr/local/include/readline
>  ...Found libncurses in /usr/lib/
>  ...Library ncurses needed by readline
>  Using GNU readline, version 6.2
>  However, the final step "make install" does not work and I still get a gp without readline at the end (it's the correct version of gp though). Make install gets stuck curing the compilation
>  of the tex files, with the following error message :

Which OS X release are you using ?

Please send the whole output from Configure and make.

How did you manage to compiler PARI 2.3.2 with readline ?