Frank Thorne on Fri, 10 Feb 2012 18:45:45 +0100

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

Re: Installation issue with GMP 5.0.2

Bill and James, thank you very much for your help!

James is right: it is important that libgmp and gmp header are from the same
installation. Do
./Configure --with-gmp=/opt/local
and check that it prints:
...Found libgmp in /opt/local/lib
...Found gmp header in /opt/local/include

This absolutely worked. Thank you! I tried doing as you suggested, it printed what you said, it ran fine, and when I ran PARI/GP it said that it is now working with GMP.

Unfortunately I ran into one more issue, this time with Belabas's cubic. My followup question may be a little bit more off topic for this group, so please don't concern yourself if you don't know. Anyway, I tried to make cubic, and I got the following error message:

frank-thornes-macbook-2:cubic-1.2 frankthorne$ make cubic
gcc -L/opt/local/lib -Wl,-rpath,/opt/local/lib -o cubic util.o ccubic.o rcubic.o -lgmp -lpari -lm
Undefined symbols:
  "_TIMERstart", referenced from:
      _main in util.o
  "_TIMER", referenced from:
      _main in util.o
  "_gprealloc", referenced from:
      _main in util.o
  "_gpmalloc", referenced from:
      _init_TI in util.o
      _main in util.o
      _main in util.o
ld: symbol(s) not found
collect2: ld returned 1 exit status
make: *** [cubic] Error 1

After reading the README coming with cubic, I made the following change to the Makefile there:


I also reinstalled PARI/GP with the command

./Configure --with-gmp=/opt/local --prefix=/opt/local

which seems to have had the desired effect of installing the PARI/GP libraries in /opt/local, where the GMP libraries are. (I looked in /opt/local/lib and /opt/local/include/pari and verified that PARI/GP files were installed there.) However, I again got the error above.

A Google search turned up nothing, so I presume this is something fairly specific.

If this is outside the bounds of what you know, then thank you, you've been quite helpful already. If you have any idea how to fix this I would be quite grateful to hear it.

Thank you! -Frank