Bill Allombert on Mon, 29 Aug 2005 23:03:22 +0200

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

Re: AMD64 compile problem

On Mon, Aug 29, 2005 at 04:04:17PM +0100, wrote:
> I cannot get pari/gp to compile on my AMD64 linux system (Fedora core 4 x86_64, gcc-4.0.1).
> There seems to be two major problems:
> 1. non-compatible types in gp_rl.c
> 2. linkage problem with kernel.c
> Adding "-fPIC" to the gcc options seems to fix problem 2, but the resulting gp program crashes at startup.
> no doubt due to problem 1.
> Any hints?

You are probably using PARI/GP 2.1 which does not completly support
amd64 and gcc 4.0 (it was released a long time ago). I would suggest you
try the developement branch 2.2.10

I might get around to fix PARI 2.1 in CVS but I would prefer
2.3 get released before I have to do that.