Jean-Marc Sac-Epee on Wed, 18 Feb 2004 15:36:21 +0100

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

2.1.5 installation & Linux Mandrake 9.2


I am an ex-pari user. I used pari during 4 or 5 years via C programs.

Now, I want to program with pari again... but I fail to install the 2.1.5 version properly!!! :-(

Of course, it was easy to install pari-2.1.5-1mdk.i586.rpm , and then gp is OK, but it is not the good way to use pari as a library...

I have a PC with Linux Mandrake 9.2

After ./Configure

I typed

make gp

and get

[root@hal pari-2.1.5]# make gp
cd Olinux-i686; make gp
make[1]: Entering directory `/usr/local/pari-2.1.5/Olinux-i686'
/usr/bin/gcc -c -O3 -DGCC_INLINE -Wall -Wno-implicit -fomit-frame-pointer -I. -I../src/headers -I../src/language -o gp.o ../src/gp/gp.c /usr/bin/gcc -c -O3 -DGCC_INLINE -Wall -Wno-implicit -fomit-frame-pointer -I. -I../src/headers -I../src/language -o gp_rl.o ../src/gp/gp_rl.c /usr/bin/gcc -c -O3 -DGCC_INLINE -Wall -Wno-implicit -fomit-frame-pointer -I. -I../src/headers -o buch2.o ../src/basemath/buch2.c ../src/basemath/buch2.c:1782: internal compiler error: in remove_edge, at callgraph.c:189
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:> for instructions.
make[1]: *** [buch2.o] Erreur 1
make[1]: Leaving directory `/usr/local/pari-2.1.5/Olinux-i686'
make: *** [gp] Erreur 2
[root@hal pari-2.1.5]#

Could anybody help me to install my old beloved pari? ;-)


Jean-Marc Sac-Epée, Ingénieur de Recherches en Calcul Scientifique,
Laboratoire de Mathématiques, UMR 7122, Université de Metz,
Tél 03 87 54 72 69  Fax 03 87 31 52 73