Pierre DOMINIQUE on Mon, 11 Feb 2002 15:19:24 +0100 (CET)

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

pb with pari 2.1.1 install on HP-UX 11.11

Hello there Pari lovers :) !

I'd like to use the Net::SSH Perl module but this
module requires other modules, such as Math::Pari,
which are pretty tough to install (I had a problem
with Math::GMP as well ;-). 
Using Gcc or HP's ansi C compiler I get this kind of
error from ld when building Pari : "DP relative code
in file kernel.o - shared library must be position
independent. Use +z or +Z to recompile."
I used the "./Configure -a" command to ensure
everything is OK and I told Configure to use the +z
flag with cc. 

Anyone installed Pari on HP-UX 11.11 successfully ?
Please help !


PS : I looked at the MACHINES file in the Pari dir but
unfortunately there's nothing special about HP-UX
11.11 and the tricks given for other HP-UX didn't work
in this case...

Do You Yahoo!? -- Une adresse @yahoo.fr gratuite et en français !
Yahoo! Mail : http://fr.mail.yahoo.fr