Karim BELABAS on Wed, 14 Nov 2001 19:32:02 +0100 (MET)

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

Re: Errors in compilation of pari-2.1.1 on Linux mandrake 8.1

On Wed, 14 Nov 2001, christine noot-huyghe wrote:
> I want to install pari-2.1.1 on Linux mandrake 8.1 (gcc version:
> gcc-2.96-0.62mdk).
> I tried the RPM but got this error message:
> error: failed dependencies:
> libreadline.so.4 is needed by pari-2.1.1-1
> This is strange because libreadline.so.4 is installed on my system, under
> /lib.
> I also get some errors with readline, during the compilation:

I do not understand the rpm error, but it looks like the 'readline' package
only installs the shared libraries (and docs). In order to compile PARI you
probably need readline-devel or something like this. Basically, you need

(and history.h for very recent alpha versions of PARI).


Karim Belabas                    email: Karim.Belabas@math.u-psud.fr
Dep. de Mathematiques, Bat. 425
Universite Paris-Sud             Tel: (00 33) 1 69 15 57 48
F-91405 Orsay (France)           Fax: (00 33) 1 69 15 60 19
PARI/GP Home Page: http://www.parigp-home.de/