Igor Schein on Wed, 28 Jul 1999 12:43:00 -0400

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

Re: 64bit executable under Solaris 2.7

On Mon, Jul 19, 1999 at 03:18:26PM +0100, Prof. J. E. Cremona wrote:
> After Igor's posting I tried quadhilbert(777) on 2.0.16 (beta) on an
> Alpha (DEC unix) and it also gave problems: the second line below was
> repeated ad infinitum (or at least until I stopped it).  This was
> compiled with gcc version 2.8.1.
> ? quadhilbert(777)
> Unaligned access pid=5492 <gp-2.0> va=0x140a69cbc pc=0x3ffbffbc9b4 ra=0x3ffbffbc960 inst=0xb4870000
> John

This could be either gcc 2.8.1 problem or Tru64 problem.
I got my alpha machine, installed Linux RedHat 6.0 on it, and built
2.0.16 with egcs 1.1.2 ( which is the same as gcc-2.91.66 ).  The
above worked fine.  



gcc-2.95 is about to be released in the next few weeks.  I'll be
curious to see if it will compile 64bit PARI binary for Sparc and 
Alpha (it definitely should be fine for 32bit)