Ilya Zakharevich on Fri, 2 Jul 1999 18:36:22 -0400 (EDT)

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

[BUG 2.0.16] Wrong LD_LIBRARY_PATH: bench not working

I manually edited Makefile to fix wrong RLLIBS Configure put there,
    make dobench
would die with

  * Testing objets        for gp-sta..Killed
  BUG [0] for gp-dyn..Killed
  BUG [0]

etc.  The reason is that my recommendations for LD_LIBRARY_PATH were
ignored, and a wrong data was put there.

To fix this, I needed

--- ./o.solaris-sparcv9/Makefile~	Thu Jul  1 04:40:51 1999
+++ ./o.solaris-sparcv9/Makefile	Fri Jul  2 18:28:22 1999
@@ -95,7 +95,7 @@ cleantest:
 	$(RM) out.*
-	@env LD_LIBRARY_PATH=  ../src/test/dotest 4
+	@env "LD_LIBRARY_PATH=.;$$LD_LIBRARY_PATH"  ../src/test/dotest 4
 	@env LD_LIBRARY_PATH=  ../src/test/dotest 4 -c

Btw, here are results of benchmarks:

* Testing objets        for gp-sta..TIME=30     for gp-dyn..TIME=20
* Testing analyz        for gp-sta..TIME=990    for gp-dyn..TIME=1080
* Testing number        for gp-sta..TIME=630    for gp-dyn..TIME=510
* Testing polyser       for gp-sta..TIME=180    for gp-dyn..TIME=170
* Testing linear        for gp-sta..TIME=220    for gp-dyn..TIME=220
* Testing elliptic      for gp-sta..TIME=680    for gp-dyn..TIME=480
* Testing sumiter       for gp-sta..TIME=1550   for gp-dyn..TIME=1150
* Testing graph         for gp-sta..TIME=330    for gp-dyn..TIME=250
* Testing program       for gp-sta..TIME=590    for gp-dyn..TIME=630
* Testing trans         for gp-sta..TIME=1820   for gp-dyn..TIME=1620
* Testing nfields       for gp-sta..TIME=9940   for gp-dyn..TIME=8650
+++ Total bench for gp-sta is 9008
+++ Total bench for gp-dyn is 7860

(Solaris 7, Ultra5 270MHz 128M).  Why dynamic is quickier than static?!