Igor Schein on Mon, 31 May 1999 15:31:23 -0400

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

undetermined bug

Hi,  I found a what appears to be a bug related to factorization.
However, I can only reproduce it when I run quadhilbert(7449).
SIGSEGV occurs right after the final MPQS, when all factors of the
discriminant had been found. The problem is it takes 10min with
optimized version ( and about 30min with debugging version) on
Ultra-60 to reach to the point of SIGSEGV.  I tried different ways to
speed it up, but to no avail.  I did factorization separately, but the
bug doesn't occur.  I tried eliminating some of the factors by using
addprimes(), but then the bug dissappears too.  Here's a relevant gdb

Program received signal SIGSEGV, Segmentation fault.
0x23bb00 in gerepile (av=10852552, tetpil=10851476, q=0x0) at ../src/language/init.c:928
928	      if ((ulong)*a < (ulong)av && (ulong)*a >= (ulong)avma)
(gdb) bt
#0  0x23bb00 in gerepile (av=10852552, tetpil=10851476, q=0x0) at ../src/language/init.c:928
#1  0x23b34c in gerepilemanysp (av=10852552, tetpil=10851476, gptr=0xefffea40, n=2) at ../src/language/init.c:832
#2  0x160620 in ifac_decomp (n=0xaec07c, hint=0) at ../src/basemath/ifactor1.c:3304
#3  0x6e0b8 in auxdecomp0 (n=0xaec07c, all=1, hint=0) at ../src/basemath/arith2.c:457
#4  0x6e16c in decomp (n=0xa59bec) at ../src/basemath/arith2.c:479
#5  0x179764 in factor (x=0xa59bec) at ../src/basemath/polarit2.c:812
#6  0xa8954 in idealfactor (nf=0xa70bcc, x=0xa5a12c) at ../src/basemath/base4.c:565
#7  0x90c68 in rnfround2all (nf=0xa70bcc, pol=0xa5cbec, all=1) at ../src/basemath/base2.c:2406
#8  0x91744 in rnfpseudobasis (nf=0xa70bcc, pol=0xa5cbec) at ../src/basemath/base2.c:2473
#9  0x97640 in makebasis (nf=0xa70bcc, pol=0xa5cbec) at ../src/basemath/base2.c:3229
#10 0xd46e0 in rnfpolredabs (nf=0xa70bcc, relpol=0xa5d090, flag=2, prec=11) at ../src/basemath/bibli1.c:2220
#11 0x20cae4 in AllStark (data=0xa85cec, nf=0xa70bcc, flag=2, newprec=11) at ../src/modules/stark.c:2986
#12 0x20d080 in quadhilbertreal (D=0xa89f8c, prec=5) at ../src/modules/stark.c:3064
#13 0xe1db4 in quadhilbert (D=0xa89f8c, flag=0xae4230, prec=5) at ../src/basemath/buch1.c:270
#14 0x224fb4 in identifier () at ../src/language/anal.c:1380
#15 0x2213a4 in truc () at ../src/language/anal.c:721
#16 0x220d7c in facteur () at ../src/language/anal.c:656
#17 0x21fc40 in expr () at ../src/language/anal.c:424
#18 0x21f9f0 in seq () at ../src/language/anal.c:392
#19 0x21ee24 in lisseq0 (t=0xae5a20 "quadhilbert(7449)", f=0x21f8b8 <seq>) at ../src/language/anal.c:158
#20 0x21ef24 in lisseq (t=0xae5a20 "quadhilbert(7449)") at ../src/language/anal.c:172
#21 0x21f004 in readseq (c=0xae5a20 "quadhilbert(7449)", strict=1) at ../src/language/anal.c:198
#22 0x24d408 in gp_main_loop () at ../src/gp/gp.c:1964
#23 0x24e340 in main (argc=4, argv=0xeffff82c) at ../src/gp/gp.c:2180
(gdb) p (ulong)*a
Cannot access memory at address 0xe7c000.

q being NULL is also suspicious.