Arno W Peters on 04 Aug 1998 15:22:04 +0200

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

Unable to compile on UltraSparc

I was unable to compile PARI/GP on an UltraSparc-1 using the default
configuration as determined by the Configure script.  I have tried
*all* of the options from the list of SPARC specific options to as as
given in the list below.  Each and every one fails with the same error

Also note that the configure script find the GNU bin utilities for
most programs but insists on using SUN's ld in /usr/ucb/bin; GNU's ld
is in /usr/local/bin.

*** Output from Configure:

Checking echo to see how to suppress newlines...
...using -n.
Looking for some tools first ...
...ld is /usr/ucb/ld
...zcat is /usr/bin/zcat
...gunzip is /usr/local/bin/gunzip
...gzip is /usr/local/bin/gzip
...ranlib is /usr/local/bin/ranlib
...perl is /usr/local/bin/perl
...ctags is /usr/local/bin/ctags
...emacs is /usr/local/bin/emacs
Building for architecture: UltraSparc (MicroSparc kernel)
Checking for optional libraries and headers...
...Found libX11 in /softs/X11R6/lib
...Extra Libraries are -lsocket -lnsl
...Found X11 header files in /softs/X11R6/include/X11
...Found libreadline in /usr/local/lib
...Found libtermcap in /usr/ccs/lib
...Found GNU readline header in /usr/local/include/readline
...Library termcap needed by readline
Looking for an assembler ... is /usr/local/bin/as
...Hum, this looks like GNU as
Assembler is           /usr/local/bin/as  
Looking for the compilers ... is /usr/ucb/cc
...gcc is /usr/local/bin/gcc
GNU compiler version 2.8.1
C compiler is          /usr/local/bin/gcc  -O2  -mv8 
C PreProcessor is      /usr/local/bin/gcc -E -I.
Executable linker is   /usr/local/bin/gcc  -O2  -mv8 
Dynamic Lib linker is  /usr/ucb/ld  -G -h $@
The internal byte representation of your long integers is 4321.
Checking some common types...
...Found ulong.
Looking in C lib for some symbols...
...I did not find exp2.
...Found strftime.
...Found getrusage.
...Found sigrelse.
...Found dlopen.
Installation prefix ? [/usr/local]
..."gp" executable ? [/usr/local/bin]
..."pari" library ? [/usr/local/lib]
...include files ? [/usr/local/include/pari]
...manual pages ? [/usr/local/man/man1]
...documentation, help scripts, and emacs macros ? [/usr/local/lib/pari]
...miscellaneous data (galois resolvents) ? [/usr/local/lib/pari/data]
Default is dynamic executable and shared library
Extracting examples/Makefile.sparcv9-solaris
Extracting o.solaris-sparcv9/Makefile
Extracting Makefile
Extracting o.solaris-sparcv9/paricfg.h
Extracting scripts and macros doc emacs
Shall we try to build pari 2.0.11 (beta) now (y/n)? [n]
Ok. Type "make install" when you are ready
Bye !

*** Output and error message by running make:

cd o.solaris-sparcv9; make clean
make[1]: Entering directory `/tima/peters/src/pari-2.0.11.beta/o.solaris-sparcv9'
rm -f out.*
rm -f *.o *.s pariinl.h libpari.* gp-dyn gp-sta
make[1]: Leaving directory `/tima/peters/src/pari-2.0.11.beta/o.solaris-sparcv9'
cd o.solaris-sparcv9; make gp
make[1]: Entering directory `/tima/peters/src/pari-2.0.11.beta/o.solaris-sparcv9'
cat ../src/kernel/sparcv8/level0.h ../src/kernel/none/level1.h > pariinl.h
/usr/local/bin/gcc -c -O2  -mv8  -I. -I../src/headers -I../src/language -I/usr/local/include -o gp.o ../src/gp/gp.c
/usr/local/bin/gcc -c -O2  -mv8  -I. -I../src/headers -I../src/graph -o gp_init.o ../src/gp/gp_init.c
/usr/local/bin/gcc -c -O2  -mv8  -I. -I../src/headers -I../src/language -I/usr/local/include -o gp_rl.o ../src/gp/gp_rl.c
/usr/local/bin/gcc -c -O2  -mv8  -I. -I../src/headers -I/softs/X11R6/include -o plot.o ../src/graph/plotX.c
/usr/local/bin/gcc -c -O2  -mv8  -I. -I../src/headers -I../src/graph -o plotport.o ../src/graph/plotport.c
/usr/local/bin/as  -o kernel.o ../src/kernel/sparcv8/level0.s
../src/kernel/sparcv8/level0.s: Assembler messages:
../src/kernel/sparcv8/level0.s:30: Error: Unknown opcode: `globl'
../src/kernel/sparcv8/level0.s:31: Error: Unknown opcode: `globl'
../src/kernel/sparcv8/level0.s:32: Error: Unknown opcode: `globl'
../src/kernel/sparcv8/level0.s:34: Fatal error: Unknown opcode: `c(addll):sethi %hi(C(overflow)),%o3'
make[1]: *** [kernel.o] Error 1
make[1]: Leaving directory `/tima/peters/src/pari-2.0.11.beta/o.solaris-sparcv9'
make: *** [gp] Error 2

*** Version of programs not shown by the configure script:

$ uname -a
SunOS cime907 5.5.1 Generic sun4u sparc SUNW,Ultra-1

$ /usr/local/bin/as --version
GNU assembler 2.9
Copyright 1997 Free Software Foundation, Inc.
This program is free software; you may redistribute it under the terms of
the GNU General Public License.  This program has absolutely no warranty.
This assembler was configured for a target of `sparc-sun-solaris2.5.1'.

$ /usr/local/bin/as --help
SPARC options:
-Av6 | -Av7 | -Av8 | -Asparclet | -Asparclite | -Av8plus | -Av8plusa | -Av9 | -Av9a | 
-xarch=v8plus | -xarch=v8plusa
                        specify variant of SPARC architecture

Arno W Peters