Roland Dreier on Tue, 3 Mar 1998 20:19:57 +0100

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

Strange behavior with Red Hat linux 5.0

I am having a bizarre problem with gp.  Actually, it is more likely
something wrong with the setup of my system, but I am hoping someone
more familiar with gp's innards can help me diagnose it.

I recently upgraded my linux installation from Red Hat 4.0 to Red Hat
5.0.  Before the upgrade, I had no problems with pari-2.0.6.  As part
of that upgrade, /etc/passwd got rebuilt (that may or may not be
relevant).  Now, when I run gp from the account "dreier" which has UID
500, I get a SEGV the _second_ time the call to getpwuid on the line
(line # 1731 in language/es.c)

  if (!*s || *s == '/') p = getpwuid(geteuid());

is reached (ie when PARI is expanding the path "~/gp").  Running gp as
root or as a user with UID 501 works fine.  Replacing the geteuid()
with 501 works fine, while replacing it with 500 causes the crash on
the second call.  The working directory I'm in when I run gp makes no

If I write a program that just does 

  for (i= 0; i<1000; i++) p = getpwuid(geteuid());

that works fine as every user.

Any ideas??