Bill Allombert on Mon, 21 Sep 2009 11:26:56 +0200

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

Re: pari-2.3.5 prerelease

On Sun, Sep 20, 2009 at 02:03:25PM +0100, Jason Moxham wrote:
> On Saturday 19 September 2009 16:20:45 Bill Allombert wrote:
> > Dear PARI-dev,
> >
> > I made a prerelease version of PARI 2.3.5 (stable):
> > <>
> > Please test.
> >
> > The issue, though, is the Windows binary. I do not have a Window
> > environment and Karim had some trouble building the binary for PARI 2.3.4
> >
> > Cheers,
> > Bill.
> Hi
> I built and tested 2.3.5 on cygwin , I haven't tried the optional packages 
> yet , but no problems to report. I can have a go at building the windows 
> binary if I can/knew how.

My guess is that you have to build PARI as usual, move to the directory
'Odos' and use a tool called 'NullSoft Installer' and feed it the file 
pari.nsi and hope for the best.

As far as I can see you need to have:
-- perl, readline and fltk
-- the extra PARI package 'galdata'
-- to compiler acro.c to acro.exe (in Odos)
You also need to update pari.nsi for the new version.

But I am not sure if it is worth your time to try: I probably missed
something important.