Jason Moxham on Wed, 15 Jul 2009 02:11:18 +0200

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

Re: Re: Some bugs?

----- Original Message ----- From: "Bill Allombert" <Bill.Allombert@math.u-bordeaux1.fr>
To: <pari-dev@list.cr.yp.to>
Sent: Friday, July 10, 2009 9:01 PM
Subject: Re: Re: Some bugs?

On Thu, Jul 09, 2009 at 02:46:20AM +0100, Jason Moxham wrote:
On Wed, Jul 08, 2009 at 05:01:13AM +0100, Jason Moxham wrote:
I try to narrow it down some time this week,
in the meantime , some more bugs :)

This time pari svn , I make distrib under cygwin to remove the dependance
on perl and bison , then make gp under mingw32

/mingw/bin/gcc  -c -O3 -Wall -fno-strict-aliasing -fomit-frame-pointer
-I. -I../src/headers  -o default.o ../src/language/default.c
/mingw/bin/gcc  -c -O3 -Wall -fno-strict-aliasing -fomit-frame-pointer
-I. -I../src/headers  -o errmsg.o ../src/language/errmsg.c
/mingw/bin/gcc  -c -O3 -Wall -fno-strict-aliasing -fomit-frame-pointer
-I. -I../src/headers  -o es.o ../src/language/es.c
../src/language/es.c:3300:17: pwd.h: No such file or directory

The problem is that mingw32 is missing the header file pwd.h


pwd.h is POSIX which mingw32 doesn't support
Currently on mingw32
#define UNIX    is defined in paricfg.h
if we undefine UNIX then it solves this problem

This seems to be the correct thing to do.

admin/pari-2.4.3"/O6.0-none-mingw32_nt:"/usr/local/lib":/usr/lib     -lm
rm -f ../gp
ln -s O6.0-none-mingw32_nt/gp-sta ../gp
ln: creating symbolic link `../gp' to `O6.0-none-mingw32_nt/gp-sta': No
such file or directory
make[1]: [../gp] Error 1 (ignored)
make[1]: Leaving directory

there is no .exe suffix on the gp and gp-sta

Probably exe_suff should be set?

gp.exe runs OK in a command prompt , but for some reason wont run in a
mingw window , so we can't run the standard make test-all


I tried the above , and it looked like it all worked , until I tried some math eg 1+2
then it crashed  , clearly the mingw32 build needs some more tweeks