Vincent Lefevre on Mon, 18 May 2009 03:07:51 +0200

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

Re: gmp header file (was: Incorrect result with GMP 4.2.4 under Mac OS X (PowerPC))

On 2009-05-18 01:27:20 +0200, Bill Allombert wrote:
> On Mon, May 18, 2009 at 12:50:17AM +0200, Vincent Lefevre wrote:
> > On 2009-05-17 15:03:22 +0200, Bill Allombert wrote:
> > > I have commite to PARI SVN (r11718) a slightly better version of
> > > this patch with improved diagnostics.
> > 
> > I wanted to try, but Configure takes a wrong header file:
> Well, you can use --with-gmp-include/--with-gmp-lib to fix that.

OK, but PARI should really take the default directories into account.
Otherwise this leads to inconsistencies. For instance, on one of my
Debian machines, Configure with no arguments gives:

Checking for optional libraries and headers...
...Found libgmp in /home/vlefevre/x86_64/lib
...Found gmp header in /usr/include

So, it takes the GMP library I've compiled myself (a new version),
but the old gmp.h header from the system!

On Mac OS X, with --with-gmp* pointing to the 32-bit GMP library with
64-bit limbs, I now get:

### Your GMP library ABI is unsupported.
### Building without GNU MP support

This is correct, but I'd say that Configure should fail if any
--with-gmp* option has been used.

Vincent Lefèvre <> - Web: <>
100% accessible validated (X)HTML - Blog: <>
Work: CR INRIA - computer arithmetic / Arenaire project (LIP, ENS-Lyon)