Bill Allombert on Fri, 22 Dec 2006 18:02:40 +0100

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

Re: GMP with stable v. development release

On Thu, Dec 07, 2006 at 02:06:42PM -0800, Jeffrey Stopple wrote:
> Hi All, 
> I just noticed the PARI/GP webpage says 'The GNU MP library can be used 
> as a replacement for the native multiprecision kernel of the 
> development release.'  The documentation does not mention this 
> restriction.  Is it really not possible to configure --with-gmp the 
> stable release?   

The stable release should work with GNU MP. The web page have been
fixed, thanks!

> (Right now I can't configure --with-gmp at all.  In GMP 4.2:  'The 
> solib numbers for the shared version of libgmp and libgmpxx are very 
> wrong, making it appear older than version 4.1.4.'  Then ./Configure 
> --with-gmp  gives me # Your version of GMP is too old for PARI.  Please 
> upgrade 

I gather this happens on Mas OS X. This looks like a problem in the
way the GMP shared library was built.

Maybe try to link with the static GMP library instead or install
GMP 4.1.4.