Vincent Lefevre on Fri, 28 Oct 2005 17:53:01 +0200

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

Configure bug when CPPFLAGS is set

I've tried to compile pari 2.2.11 on Mac OS X (from an updated
DarwinPorts portfile), but get the following error:

/usr/bin/gcc  -c -O3 -DGCC_INLINE -Wall -fno-strict-aliasing -fomit-frame-pointer  -no-cpp-precomp  -DBOTH_GNUPLOT_AND_X11 -I. -I../src/headers -I../src/language -I/usr/include -o gp_rl.o ../src/gp/gp_rl.c
../src/gp/gp_rl.c:72: error: conflicting types for 'rl_message'
../src/gp/gp_rl.c:72: note: a parameter list with an ellipsis can't match an empty parameter name list declaration
/opt/local/include/readline/readline.h:375: error: previous declaration of 'rl_message' was here
../src/gp/gp_rl.c: In function 'pari_rl_forward_sexp':
../src/gp/gp_rl.c:268: warning: implicit declaration of function 'ding'
../src/gp/gp_rl.c: In function 'get_matches':
../src/gp/gp_rl.c:363: warning: implicit declaration of function 'completion_matches'
../src/gp/gp_rl.c:363: warning: initialization makes pointer from integer without a cast
make[2]: *** [gp_rl.o] Error 1
make[1]: *** [gp] Error 2
make: *** [all] Error 2

Odarwin-ppc/pari.cfg contains:


though it should have been


I think the problem is the following. When I run

  sudo env LDFLAGS=-L/opt/local/lib CPPFLAGS=-I/opt/local/include ./Configure

manually, I get:

...Found readline header in /usr/include/readline

but the real header is in "/opt/local/include/readline". Hence
the failure. Configure should take some environment variables
(such as CPPFLAGS) into account to get the real header.

Vincent Lefèvre <> - Web: <>
100% accessible validated (X)HTML - Blog: <>
Work: CR INRIA - computer arithmetic / SPACES project at LORIA