Justin Walker on Sun, 16 Nov 2003 22:28:31 +0100

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

Building gp2c

Hi, again,

I have just (11/16) checked out new copies of pari and gp2c. I built and installed pari, and ran cvsinit in gp2c, after copying in the config file from /usr/local/lib/pari. I get this:

mkdir: config: File exists
config already exists.
doc/Makefile.am:13: `#' comment at start of rule is unportable
You must have automake to proceed. Sorry.

I do have 'automake', and this error is due to the 'automake' error on the preceding line ('automake' returns 1 as a result). No big deal, just FYI (the problem appears to be the commenting out of the latex line; if the comment character is at the beginning of the line, 'automake' is happy).

When I test the results (the 'make' succeeds without apparent issue), I get this:

Testing script affect...
./scripts/dotest: line 1: -o: command not found
FAIL: scripts/dotest
1 of 1 tests failed

Somehow, the creation of 'dotest' from 'dotest.in' produced this line:
command=`echo "/usr/bin/gcc -c -o %s.o -O3 -DGCC_INLINE -Wall -fomit-fram\ e-pointer -no-cpp-precomp -fno-common -I/usr/local/include %s.c && -o %s.dylib \ -shared -mimpure-text -O3 -DGCC_INLINE -Wall -fomit-frame-pointer -no-cpp-preco\
mp -fno-common %s.o " | sed -e s/%s/$i.gp/g`

A similar line is present in scripts/Makefile.

Any ideas?



Justin C. Walker, Curmudgeon-At-Large  *
Institute for General Semantics | "Weaseling out of things is what
                                       |  separates us from the animals.
                                       |  Well, except the weasel."
                                       |        - Homer J Simpson