Bill Allombert on Tue, 14 Oct 2003 11:19:28 +0200

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

Re: 64 bit installation on sparcv9

On Tue, Oct 14, 2003 at 11:06:34AM +0200, Franck MICHEL wrote:
> Igor Schein wrote:
> >You need to do either
> >
> >env CC="gcc -m64" ./Configure ...
> >
> >or
> >
> >env CC="cc -xarch=v9" CFLAGS="-xarch=v9" ./Configure ...
> >
> >depending on whethere you're using GNU cc or Forte cc.
> Unfortunately, it does not work. I've tried Pari 2.2.7, Pari 2.2.7 with
> GMP, and Pari 2.1.5, with Gcc and Forte cc, and I always failed. I would
> like to use Pari 2.2.7 with GMP but I prefered to check also other
> versions; errors messages are not the same.

You must use 

Configure --kernel=none-none
or to use GMP
Configure --kernel=none-gmp.

Assembly kernels do not support 64 bit. Guillaume Hanrot has tried
to write a Assembly kernel for parc64 but there were no gain
over the poortable version, because sparc64 has no 64x64 bits