Frédéric Oger on 02 Oct 2002 09:10:01 +0200

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

Problem with Perl Math::Pari on TRU64

I'm trying to install Math::Pari-2.010305, pari-2.1.4 with perl version
5.8 on Compaq Tru64 Unix v4.0d in order to install  Net-SSH module.  I
am running into some problems with thousands "Unaligned access" errors
when I run 'make test'. 

The 'make' returns no errors

Also tried on another Tru64 with perl 5.6.1 installed. Same problem

Can someone lend me a clue on how to get 'make test' working?  Perl
configuration, and output from Makefile.PL/make/make test follow below:

Summary of my perl5 (revision 5.0 version 8 subversion 0) configuration:
    osname=dec_osf, osvers=4.0d, archname=alpha-dec_osf
    uname='osf1 v4.0 878 alpha '
    hint=recommended, useposix=true, d_sigaction=define
    usethreads=undef use5005threads=undef useithreads=undef
    useperlio=define d_sfio=undef uselargefiles=define usesocks=undef
    use64bitint=define use64bitall=define uselongdouble=undef
    usemymalloc=n, bincompat5005=undef
    cc='cc', ccflags ='-std -D_INTRINSICS -fprm d -ieee
-I/usr/local/include -DLANGUAGE_C',
    cppflags='-std -D_INTRINSICS -ieee -I/usr/local/include
    ccversion='V5.6-071', gccversion='', gccosandvers=''
    intsize=4, longsize=8, ptrsize=8, doublesize=8, byteorder=12345678
    d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=8
    ivtype='long', ivsize=8, nvtype='double', nvsize=8, Off_t='off_t',
    alignbytes=8, prototype=define
  Linker and Libraries:
    ld='ld', ldflags =' -L/usr/local/lib'
    libpth=/usr/local/lib /usr/shlib /usr/ccs/lib /usr/lib/cmplrs/cc
/usr/lib /var/shlib
    libs=-ldbm -ldb -lm -lutil
    perllibs=-lm -lutil
    libc=/usr/shlib/, so=so, useshrplib=true,
  Dynamic Linking:
    dlsrc=dl_dlopen.xs, dlext=so, d_dlsymun=undef, ccdlflags=' 
    cccdlflags=' ', lddlflags='-shared -expect_unresolved "*" -msym -std
-s -L/usr/local/lib'

Characteristics of this binary (from libperl): 
  Compile-time options: USE_64_BIT_INT USE_64_BIT_ALL USE_LARGE_FILES
  Built under dec_osf
  Compiled at Oct  1 2002 11:34:06

perl Makefile.PL

Found GP/PARI build directory in pari-2.1.4
     (integer-formatted version 2001004).
...Will not overwrite libPARI/paricfg.h...  (remove it manually if
   You may also want to remove libPARI/paricfg.h if your configuration
   from the time of the first build in this directory...
Problems with numeric interface codes noted:
  May be harmless: non-unique string interfaces for numeric interfaces:
    29 meaning "GGp GG GGD0,L,p"
  Possible problems with Math::Pari interface to GP/PARI:
	unexpected value of string interfaces for numeric interfaces:
    29 meaning "GGp GG GGD0,L,p" (was meaning "GGp" in 2.1.3)
...Processor of family `alpha' detected
...I will use assembler build of type 'alpha'.
Writing Makefile for Math::PARI::libPARI
Writing Makefile for Math::Pari


cp libPARI.dumb.pod blib/lib/Math/libPARI.dumb.pod
cp blib/lib/Math/
cp blib/lib/Math/
cp libPARI.pod blib/lib/Math/libPARI.pod
cd libPARI && make LIB="" LIBPERL_A="libperl.a" LINKTYPE="dynamic"
make[1]: Entering directory

cc: Warning: .././pari-2.1.4/src/graph/Gnuplot.h, line 433: Non-void
function "myterm_table_not_loaded_di" does not contain a return
static double
cc: Warning: .././pari-2.1.4/src/graph/Gnuplot.h, line 655: Non-void
function "StartOutput" does not contain a return statement.
cc: Warning: .././pari-2.1.4/src/graph/Gnuplot.h, line 658: Non-void
function "EndOutput" does not contain a return statement.


then the 'make test' return thousands of:

Unaligned access pid=30583 <perl> va=0x1404e654c pc=0x300000a3e60
ra=0x300000a3e40 inst=0xb40b0008
Unaligned access pid=30583 <perl> va=0x1404e6544 pc=0x3000008da64
ra=0x30000088780 inst=0xa4090000
Unaligned access pid=30583 <perl> va=0x1404e65b4 pc=0x3000008daac
ra=0x30000088780 inst=0xa6310000
Unaligned access pid=30583 <perl> va=0x1404e6544 pc=0x3000008dac8
ra=0x30000088780 inst=0xa6490000
Unaligned access pid=30583 <perl> va=0x1404e65b4 pc=0x3000008dae4
ra=0x30000088780 inst=0xa6730000
Unaligned access pid=30583 <perl> va=0x1404e654c pc=0x300000a1a10
ra=0x3000008dea0 inst=0xa4500008
Unaligned access pid=30583 <perl> va=0x1404e65bc pc=0x300000a1a14
ra=0x3000008dea0 inst=0xb4510008
Unaligned access pid=30583 <perl> va=0x1404e654c pc=0x300000a1a18
ra=0x3000008dea0 inst=0xa4700008
Unaligned access pid=30583 <perl> va=0x1404e6544 pc=0x300000a1a44
ra=0x3000008dea0 inst=0xa4700000
Unaligned access pid=30583 <perl> va=0x1404e65b4 pc=0x300000a1a58
ra=0x3000008dea0 inst=0xa4910000

My CC version is : DEC C V5.6-071 on Digital UNIX V4.0 (Rev. 878)

Does someone has any solution ?

Kind regards,

Fred. Oger

Frédéric Oger
Service Informatique de la Faculté des Sciences
Bâtiment Pierre Curie - Rue du Compas, 2
1348  Louvain-la-Neuve
Phone: +32-10-47.38.79
Fax: +32-10-47.38.78